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CONNECTING UBUNTU 15.04 WITH SONY ERICSSON XPERIA 

ST25I ANDROID VIA MTP

I've got a new handheld device Sony Ericsson Xperia ST25i with Android operating 

system recently. This device has internal storage only, it has no external storage. I tried 

to connect it in my Ubuntu 12.04 but my file manager (Dolphin) could only read and 

could not write into its storage. And you know, Sony PC Companion program (tool for 

transferring files into Xperia) is not available for Linux until today. So, I try Ubuntu 15.04 

today. You may do it from LiveCD. Out of the box, Ubuntu detects my Xperia easily and I 

can read or write any files (create folder, copy MP3, copy images, etc.) into my Xperia. 

You don't need to install anything. By using this, you don't need Sony PC Companion 

again. I want to share it here. 

Connecting Device to PC

 

Connect your Xperia into USB port in PC with USB cable.

Ubuntu Will Detect It

 

In my Ubuntu 15.05, a new icon appears on the 

left Launcher. Its label is SEMC HSUSB Device. 

Yes, this is my Xperia device internal storage 

icon.

Open Device in File Manager

 

Click that icon on Launcher, Nautilus file 

manager will open. You should see an icon for 

internal storage. Open that icon. Now you see 

all folders from your Xperia appears inside Nautilus. This means your Ubuntu mounts 

Xperia device. 
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Transfer Files

 

You can now transfer files from PC to Xperia or from Xperia to PC. Yes, in both 

directions. You can delete file inside Xperia, you can make folder inside it, you can search 

file you want inside.

Unmount Device

 

After doing all you needs, you must unmount Xperia. To do it, click on Eject icon on 

Nautilus. Do this always in you want to take Xperia out from PC. Do this to avoid any 

power failure that can be happened anytime. Enjoy.

Technical Information

 

Why Ubuntu 15.04 can detect MTP device (Sony Ericcson Xperia ST25i) out of the box? 
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The reason is because it has libmtp and some other related tools built-in. Just use dpkg -l 

| grep mtp to see this information.
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LIBREOFFICE WRITER EQUATION EDITOR USAGE EXAMPLES

Many people ask LibreOffice Team to create equation editor in Writer. Actually, there is 

already that equation editor. LibreOffice Writer equation editor done with LibreOffice 

Math. And LibreOffice doesn't call it equation, LibreOffice calls it formula. We just need 

to know how to use it. Here, we will insert equations inside Writer document.

Write A Document

 

What we need to demonstrate, is just creating a simple document like this. We want to 

insert Einstein's formula, a complex mathematic function, sin, and cos. Yes, this is just 

basic examples. You can adapt them to your needs. 

Insert An Equation

 

Basically, to insert an equation, you need to open menu Insert > Object > Formula. We 

will do this frequently.
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Insert Einstein's Formula

 

Insert formula. You will see Writer interface changes like this. You will see left panel with 

equation models choices and bottom panel as raw formula text input. You will realize 

this interface comes from LibreOffice Math. To insert Einstein's one, from left panel, 

choose Examples > double click E = mc2. You will see the formula inserted into Writer 

document. 

Insert Complex Mathematic Formula
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Two entry below Einstein's, there is a complex mathematic formula. 

Insert Sinus and Cosinus

 

If you want to such customizable formulas, use formula presets. For example, sinus and 

cosinus. You can edit the number from the bottom panel. For sinus and cosinus, you will 

find them from Functions category. Double click the function you want. 

Final Result

 

To see final result, export Writer document into PDF. Our result will be like this. 
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CREATE CUSTOM TOOLBAR ON LIBREOFFICE

When you are working with some buttons frequently, it's better you create custom 

toolbar for those frequent buttons. It's just like desktop shortcut for frequently used 

applications.

Create A New Toolbar

 

To do this, open menu View > Toolbars > Customize > open tab Toolbar > click New. 

Name your new toolbar.

Insert Buttons

 

To do this, in the same dialog, press Add button. A new dialog will appears, select a 

button from category entries > press Add. Select buttons you want. If it's enough, close 

the latest dialog, press OK on the Toolbars dialog. Your toolbar will appear immediately 

on LibreOffice toolbar place. Usually on top.
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Access It Easily

If you want to show or hide it, just open menu View > Toolbars. 
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WHERE FIREFOX SAVES XPI FILE?

When you install an add-on in Firefox, you will download .xpi file. This XPI extension is 

default format for Firefox add-on. If you have many different computers, or you often 

work with different computer, you may need to install same add-ons for Firefox. It's 

better if you know where Firefox saves XPI files so you can backup them all and install 

them on different computers. Firefox saves XPI files on

~/.mozilla/firefox/xxxx.default/extensions

You'll find xxxx with some random alphanumeric characters. You may check it if you have 

installed some add-ons. Here, you'll find .xpi files have non-human readable names. So 

you'll need to open it on archive manager if you want to know what add-on behind the 

file name. 

Note: to install an already downloaded XPI, just drag the file into opened Firefox 

window.
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BASIC GUIDE FOR LINUX MINT CINNAMON FILE MANAGER 

(NEMO)

In our latest article about Cinnamon, we told about tweaking. Now, we will give a basic 

guide about how to use Nemo. It is a file manager, a central part of Cinnamon Desktop 

and therefore a central too for Linux Mint (or any distro using it). You will learn basic 

actions in Nemo just like using Windows Explorer or Mac OS X Finder. FYI, Nemo may 

installed on Ubuntu if you dislike to use Nautilus (Ubuntu file manager). Enjoy. 

Overview

1. Menubar.

2. Toolbar (back, forward, up, reload, home, my computer).

3. Address bar. 

4. Toolbar (address toggle, new folder, search).

5. View buttons (icons, compact, details). 

6. Left panel (My Computer, Devices, Network).

7. Main area. 

8. Bottom toolbar (Folder View, Tree View, Hide Left Panel).

9. Status bar.
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10. Zoom slider. 

Concepts

Nemo has same concepts in usage compared to Windows Explorer. But Nemo has same 

concept in visual appearance compared to Mac OS X Finder.

Differences with Explorer, Nemo has Folder View default appearance in Left Panel. This 

is visually similar with Finder. You must enable Tree View if you want something like 

Explorer left panel.

Split View

In Nemo, you can split main are into two. Press F3. This is very helpful when you are 

comparing two different folders at once.

New Tab

Nemo has multitab. Press Ctrl+T to open a new tab. In a new tab, you can browse 

different place. More tabs more places. It is just like web browsing with Firefox.
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New Folder

To create new folder, right click on main area > Create > New Folder. Or, click new folder 

icon on top toolbar. Or, press Ctrl+Shift+N. 

Delete Folder

To delete a folder, click/select a folder and press Shift+Delete. This will delete folder and 

its content permanently. If you want to delete it temporarily (move it to “Recycle Bin”), 

right-click and select Delete. Or, just press Delete without Shift key. 

Address Bar

Nemo has default Breadcrumb address bar. It's similar with Finder after all. It is an 

address bar with clickable button for every folder history. If you want normal address 

bar, press Ctrl+L. To revert it into Breadcrumb, press Ctrl+L again. 

Places

If you are using Folder View, you can bookmark your favorite folder there. Just drag and 

drop your folder into Left Panel on Devices section. 

Tree View

This is something similar with your Left Panel appearances on Windows. You browse 

folders by parent and child view. To enable this, click Tree View icon on bottom toolbar. 
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Sort By

In Nemo, you can sort your files appearances by Date, Location, Name, and Size. 

Mount & Unmount

To mount (open) external device e.g. USB flash drive, plug the device and click on its 

name on Devices section on Left Panel. To unmount (safely remove), click on eject icon 

on its name.

Hide and Show Hidden Files

Nemo hides hidden files by default. To show hidden files, press Ctrl+H. To hide them 

again, press Ctrl+H too. 
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Search

To search files, press Ctrl+F and type what do you want. In newer version of Nemo, it has 

incremental search. So, the results come directly. Doesn't wait to be finished first to 

show the result.
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HOW TO USE UBUNTU FILE MANAGER (NAUTILUS)

After Nemo File Manager yesterday, now we bring you Nautilus here. Nautilus is 

predecessor for big file managers in Linux such as Nemo and Caja. We need to explain 

Nautilus in Ubuntu in one article. We hope this will help new users in Ubuntu. Enjoy. 

Overview

1. Toolbar (back and forward buttons).

2. Address bar.

3. Search button. 

4. View buttons. 

5. Sidebar. 

6. Main area.

Concepts

Nautilus is Nemo's predecessor. So they share same features. Thus, Nautilus has similar 

visual appearance with Mac OS X Finder.

Recent Nautilus doesn't have F3 (Split View) anymore.

Nautilus in Ubuntu doesn't have normal Menubar, but has global menu like Finder in Mac 

OS X.

New Tab
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To open new tab, press Ctrl+T. To close tab, press Ctrl+W. 

New Folder

To create new folder, press Ctrl+Shift+N. Or, right-click on main area > New Folder. 

Delete Folder

To delete a folder permanently, select folder > press Shift+Delete. To delete a folder 

temporarily (“Recylce Bin”), select folder > press Delete without Shift. 

Address Bar

Nautilus has breadcrumb address bar by default. Every folder of path represented as a 

button. To reveal normal address bar, press Ctrl+L. To revert back to breadcrumb again, 

press Esc.

Places

Nautilus sidebar (Left Panel) shows you your Home folders such as Desktop, Downloads, 

Documents, etc. It consists of your folders, your partitions, and network browsing 

facilities. It is similar with left panel on Finder or Explorer.
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Tree View

Nautilus doesn't have left panel tree view like Explorer or even Nemo. But Nautilus has 

tree view on main area if you are using List View mode. To enable this, open menu Edit > 

Preferences > open tab Display > check on Navigate folders in a tree.

Sort By

You may sort your files by Date, Type, Name, and Size. The most easy way to change it is 

by using Detail View like this. Just click on the black triangle. 
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Mount & Unmount

To mount a partition, just click on the partition name on Sidebar. To unmount it, just click 

on the black triangle icon.

Hide & Show Hidden Files

To show hidden files, press Ctrl+H. To hide it again, press Ctrl+H again. 

Search

To search file, press Ctrl+F. To close search mode, press Esc. 

Change Folder Icon

To change icon of a folder, right-click a folder > Properties > click folder icon > select icon 

> Open. The icon will change immediately. You will find all icons at /usr/share/icons/.
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HOW TO ADD RIGHT-CLICK CONVERT AND RESIZE IMAGES IN 

NAUTILUS

In Dolphin, by using an extension, I can do right-click to convert bulk PNG images into 

JPEG or any format. This is very effective (I use it very intensely) for my graphic design 

works. But how about Nautilus? Sure, you can do the same thing. You will need to install 

programs nautilus-image-converter (resizer) and nautilus-image-tools (converter). 

nautilus-image-converter created by GNOME team and nautilus-image-tools created by 

Atareao Team. Thank you!

Install The Resizer

To do this, install nautilus-image-converter from Ubuntu repository. I'm using Ubuntu 

15.04 and the package is already there. Install it using Ubuntu Software Center or by 

Terminal:

sudo apt-get install nautilus-image-converter  

Install The Converter

To do this, install nautilus-image-tools from unofficial repository. Atareao has created 

that unofficial in Launchpad PPA. Use these commands:

sudo add-apt-repository ppa:atareao/nautilus-extensions  

sudo apt-get update  

sudo apt-get install nautilus-image-tools  

Restart Nautilus

Use command nautilus -q in Terminal. Then open Nautilus. This will inform you that the 

Nautilus extension loaded. If this fails, just relogin.

How To Resize

Once you install nautilus-image-converter, you will notice new items on right-click menu. 

They are Resize Images... and Rotate Images.... Select images as many as you want > 

right-click > Resize Images > a window appear > select resolution from menu > resize. 
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You will notice new files created in same folder. Your original images will not deleted. 

How To Convert

Once you install nautilus-image-tools, you will notice a new item named Image Tools in 

right-click menu. To convert many PNG: select many images > Image Tools > convert > a 

window appear > select destination format e.g. JPEG > OK. You will see new JPEG files 

created. Your original images will not replaced.
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HOW TO USE XFCE FILE MANAGER (THUNAR)

After Nemo and Nautilus, now we bring you Thunar. It is one of the simplest file manager 

(graphical) available in Linux. Simple means Thunar is easy to use. We will cover some 

important features of Thunar. We hope it helps new users into Xubuntu or any XFCE 

based Linux distro.

Overview

1. Menubar.

2. Toolbar (back, forward, up, home).

3. Address bar.

4. Left panel (devices, places, and network).

5. Main area.

6. Status bar.

Concepts

• Thunar created to be simple. So it is simple both in appearance and number of 

features.  

• Thunar shares similar visual concept with Nautilus and Mac OS X Finder, especially 

its left panel. 

• Thunar has no Ctrl+F (Search Files) feature.
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• Thunar has no split view just like current Nautilus.

New Tab

To open new tab, press Ctrl+T. To close current tab, press Ctrl+W.

New Folder

To create new folder, right-click main area > Create Folder. Or, press Ctrl+Shift+N. 

Delete Folder

To delete a folder not permanently, just select > right-click > Move To Trash. To delete 

permanently, select > Shift+Delete. 

Sort By

To sort files, Thunar offers sorting based on Name, Size, Type, or Date. 

Emblem

Thunar gives ex old GNOME users what was missing from current Nautilus: emblems. 

You can attach one or two emblems to distinguish your favorite folder from another. 
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Tree

To change left panel into tree mode, open menu View > Side Pane > Tree. To revert it 

back, open menu View > Side Pane > Shortcuts. Shortcut for this is Ctrl+E. 

Send To

Thunar has Send To feature just like Explorer. For example, suppose you want to copy a 

file into USB flash drive. Right-click a file > send to > drive name.

Bookmark

To create a bookmark for a folder, drag folder icon and drop into PLACES in left panel. 

Open Terminal Here

Right-click main area > Open Terminal Here. In Xubuntu, Thunar has this feature. It will 

help you work with Terminal seamlessly.
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HOW TO USE LXDE FILE MANAGER (PCMANFM)

After Thunar, we come with PCManFM. This is the LXDE file manager. You'll find 

PCManFM in Lubuntu. PCManFM is a very lightweight file manager yet powerful. It has 

search facility, something Thunar doesn't. It has F3 Split View also, something Nautilus 

doesn't anymore. And just like another file managers available in Linux, it has multitab 

feature. We hope this article helps anyone using Lubuntu or any LXDE based Linux 

everywhere. Enjoy. 

Overview

 

1. Menubar. 

2. Toolbar (new tab, back, forward, up, home). 

3. Address bar. 

4. Left panel (places or tree). 

5. Main area. 

6. Statusbar.

Concepts

• PCManFM has simple appearance like Thunar but it has more features. 

• PCManFM has split view. 

• PCManFM has similar default left panel like OS X Finder and Nautilus but has tree 

view hidden.
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New Tab

To open new tab, press Ctrl+T. To close current tab, press Ctrl+W.

New Folder

To create a new folder, right-click main area > Create New > Folder.

Delete Folder

To delete folder not permanently, select a folder > Move to Trash. To delete 

permanently, select a folder > Shift+Delete.

Split View 

To split view, press F3. To revert it back, press F3 again.

Fullscreen

To show fullscreen mode of PCManFM, press F11.

Search Files

To search files, press Ctrl+Shift+F or access menu Tools > Find Files. 
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Open With Terminal

To open a folder in Terminal 

directly, enter a folder > open 

menu Tools > Open Current Folder 

in Terminal.

Sort Files

To sort files, right-click main area > 

Sort Files > select one criteria. You 

can sort by Name, Size, Type, and Date. 
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UBUNTU 15.10 WILY WEREWOLF AND ALL OFFICIAL FLAVORS 

RELEASED

At October 22th 2015, Ubuntu 15.04 Wily Werewolf was released. The Ubuntu 

"brothers" (Xubuntu, Lubuntu, Kubuntu, Ubuntu GNOME, Ubuntu MATE, Ubuntu Kylin, 

and UbuntuStudio) were also released. Actually there are no big changes from previous 

15.04 release but we've got some updates. We'll see what's new and of course the 

download links.

Download Ubuntu 15.10 and Flavors

Direct Torrent

Ubuntu 15.10 i386 amd64 i386 amd64

Kbuntu 15.10 i386 amd64 i386 amd64

Lubuntu 15.10 i386 amd64 i386 amd64

Ubuntu Kylin 

15.10

i386 amd64 i386 amd64

Ubuntu MATE 

15.10

i386 amd64 i386 amd64

Ubuntu GNOME 

15.10 

i386 amd64 i386 amd64

UbuntuStudio 

15.10

i386 amd64 i386 amd64

Xubuntu 15.10 i386 amd64 i386 amd64
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http://cdimage.ubuntu.com/xubuntu/releases/wily/release/xubuntu-15.10-desktop-amd64.iso.torrent
http://cdimage.ubuntu.com/ubuntustudio/releases/15.10/release/ubuntustudio-15.10-dvd-amd64.iso
http://cdimage.ubuntu.com/ubuntu-gnome/releases/15.10/release/ubuntu-gnome-15.10-desktop-amd64.iso.torrent
http://cdimage.ubuntu.com/ubuntu-mate/releases/15.10/release/ubuntu-mate-15.10-desktop-amd64.iso.torrent
http://cdimage.ubuntu.com/ubuntukylin/releases/15.10/release/ubuntukylin-15.10-desktop-amd64.iso.torrent
http://cdimage.ubuntu.com/lubuntu/releases/wily/release/lubuntu-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/kubuntu/releases/wily/release/kubuntu-15.10-desktop-amd64.iso.torrent
http://releases.ubuntu.com/15.10/ubuntu-15.10-desktop-amd64.iso.torrent
http://cdimage.ubuntu.com/xubuntu/releases/wily/release/xubuntu-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/ubuntustudio/releases/15.10/release/ubuntustudio-15.10-dvd-i386.iso
http://cdimage.ubuntu.com/ubuntu-gnome/releases/15.10/release/ubuntu-gnome-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/ubuntu-mate/releases/15.10/release/ubuntu-mate-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/ubuntukylin/releases/15.10/release/ubuntukylin-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/lubuntu/releases/wily/release/lubuntu-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/kubuntu/releases/wily/release/kubuntu-15.10-desktop-i386.iso.torrent
http://releases.ubuntu.com/15.10/ubuntu-15.10-desktop-i386.iso.torrent
http://cdimage.ubuntu.com/xubuntu/releases/wily/release/xubuntu-15.10-desktop-amd64.iso
http://cdimage.ubuntu.com/ubuntustudio/releases/15.10/release/ubuntustudio-15.10-dvd-amd64.iso
http://cdimage.ubuntu.com/ubuntu-gnome/releases/15.10/release/ubuntu-gnome-15.10-desktop-amd64.iso
http://cdimage.ubuntu.com/ubuntu-mate/releases/15.10/release/ubuntu-mate-15.10-desktop-amd64.iso
http://cdimage.ubuntu.com/ubuntukylin/releases/15.10/release/ubuntukylin-15.10-desktop-amd64.iso
http://cdimage.ubuntu.com/lubuntu/releases/wily/release/lubuntu-15.10-desktop-amd64.iso
http://cdimage.ubuntu.com/kubuntu/releases/wily/release/kubuntu-15.10-desktop-amd64.iso
http://releases.ubuntu.com/15.10/ubuntu-15.10-desktop-amd64.iso
http://cdimage.ubuntu.com/xubuntu/releases/wily/release/xubuntu-15.10-desktop-i386.iso
http://cdimage.ubuntu.com/ubuntustudio/releases/15.10/release/ubuntustudio-15.10-dvd-i386.iso
http://cdimage.ubuntu.com/ubuntu-gnome/releases/15.10/release/ubuntu-gnome-15.10-desktop-i386.iso
http://cdimage.ubuntu.com/ubuntu-mate/releases/15.10/release/ubuntu-mate-15.10-desktop-i386.iso
http://cdimage.ubuntu.com/ubuntukylin/releases/15.10/release/ubuntukylin-15.10-desktop-i386.iso
http://cdimage.ubuntu.com/lubuntu/releases/wily/release/lubuntu-15.10-desktop-i386.iso
http://cdimage.ubuntu.com/kubuntu/releases/wily/release/kubuntu-15.10-desktop-i386.iso
http://releases.ubuntu.com/15.10/ubuntu-15.10-desktop-i386.iso


Important note: you can access complete links at Ubuntu Wiki Release Page. 

New Features in Ubuntu 15.10 Wily Werewolf

Beside the new default wallpaper, there is one most noticeable thing in Unity where the 

overlay scrollbar has been deprecated, replaced with new GNOME scrollbar by Unity 

developer. This scrollbar is more visible, it's not hidden like overlay scrollbar, and this 

new scrollbar will automatically adjust its width when pointer hovers. Beside the new 

scrollbar, there are some updates:

• Linux kernel 4.2.0

• LibreOffice 5.0.2

• Firefox 41

• Chromium 45

• Nautilus 3.14.2

• Ubuntu Software Center 13.10

• Revert back from libav into ffmpeg 

(following Debian)

• Support for Steam Game Controller

New Features in 15.10 Flavors

• Ubuntu MATE gets version 1.0.3.5 for Ubuntu MATE Welcome.

• Ubuntu GNOME gets new logo and GNOME Shell 3.16. 

• Kubuntu gets KDE Plasma Desktop 5.4.0. 

• Xubuntu has replaced Abiword and Gnumeric with LibreOffice Writer and Calc. 

• Lubuntu has replaced iBus with Fcitx and added Chinese font by default. 

• Ubuntu Kylin gets Ubuntu Kylin Software Center 1.3.6. 

Upgrade From Ubuntu 15.04
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https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes


To upgrade (online) from 15.04, you can open Software Sources from menu > open 

Updates tab > set "For any newer version" in Notify me... section > open Update 

Manager program from Unity menu > you should see any new notification about 

upgrading into 15.10. Notice that you need stable internet connection and enough 

bandwidth to do upgrading.

References

https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes 

https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes/Kubuntu 

https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes/Lubuntu 

https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes/UbuntuGNOME 

https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes/UbuntuMATE 

https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes/UbuntuStudio 
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SET CUSTOM KEYBOARD SHORTCUT KEY IN UBUNTU

Ubuntu gives us easy way to bind a shortcut key with any program. Suppose you want to 

open Firefox when Win+G are pressed. Or press Win+H to open text editor. This can be 

achieved by using internal Ubuntu System Settings. You don't need to install any 

external program. 

Normal Applications

Open System Settings (gear logo) > Keyboard > Shortcuts > press Custom Shortcuts > 

press plus (+) button. Here, name your shortcut i.e. Mozilla Firefox and type the 

command. You must know the command exactly, e.g firefox is command for Mozilla 

Firefox. Another command examples such as brasero for Brasero, thunderbird for 

Mozilla Thunderbird, evince for Evince, and so on. Remember that they are case 

sensitive. Now, click the line you've created and press the keys i.e. Win+H.

Commands

Suppose you want to execute a command line from keyboard shortcut. For example, 
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turning the brightness down/up. Of course, there are thousands and more possible 

commands to bind with shortcut key. Imagine you can pipe or redirect somethings by 

just pressing shortcut key. To do it, do the same like normal applications and type the 

command line i.e. xrandr --output LVDS1 --brightness 0.5 to turn brightness down and 

xrandr --output LVDS1 --brightness 1 to turn it up. Again, after typing a command, click 

the line you've created (see right panel) and bind the keys i.e. Win+J.
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5 THINGS TO DO AFTER INSTALLING UBUNTU 15.10

We've written article about Ubuntu 15.10 release yesterday. Here we write few things 

we will always do after installing Ubuntu 15.10. All things we do can be done by point 

and click without Terminal.

1. Set Repository

Every freshly installed, Ubuntu has no multiverse and universe (two from four) 

repository enabled. You should enable them manually then Reload to sync the newly 

enabled repositories. To do this, open System Settings (gear logo) > Software & Updates 

> check multiverse and universe options > Close > Reload > wait until finish. You will 

need internet connection (approximately 10 MB downloading) to do this. After doing 

this, you can install approximately 50.000+ packages with Ubuntu Software Center.

2. Enhance Package Manager

Install Synaptic and GDebi. For long term use, you will need GDebi to install single 

packages by few click. You will need Synaptic for comprehensive install, remove, or 

upgrade any programs from your system. Ubuntu Software Center is good, but it has no 

complete control like Synaptic and GDebi.
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3. Change Wallpaper & Theme

Ubuntu comes with new fresh wallpapers. To change it, open System Settings (gear icon) 

> Appearance > select a wallpaper from right panel. To change default theme, you can 

select it from below the wallpaper options. In this example, we use Radiance theme. 

4. Desktop Settings

Few enhancements can be made here. In example, move the global menu back into 

titlebar in every application. To do this, open System Settings (gear icon) > Appearance > 

Behavior > check In the window's title bar. Beyond that, you can install Unity Tweak Tool 

from Ubuntu Software Center to control your desktop completely.

5. Set Privacy
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Ubuntu has few new privacy changes such as Lense or application logging. If you dislike 

that, you can disable that.
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MYSQL FOR BEGINNER IN UBUNTU

We find many MySQL tutorials worldwide. But this tutorial is intended for beginners in 

Ubuntu. This covers installation of MySQL itself and then some basic MySQL queries such 

as creating and updating table. This works with Kubuntu, Xubuntu, and another official 

flavors of Ubuntu because they use the same repository. We hope this helps any 

programmer comes into Ubuntu to deal with MySQL.

Installing MySQL

 

To install MySQL in Ubuntu, connect to the internet and type this command on Terminal:

sudo apt-get install mysql-server

Login into MySQL Shell

 

Open your Terminal (Ctrl+Alt+T) and type command below. This command will invoke 

mysql binary program with root user. You will be prompted to enter password 

afterwards.

/usr/bin/mysql -u root

You will always see prompt shell like this while working with MySQL: 

mysql> 

Some MySQL Rules

 

• MySQL is semi-colon ended language. You must end every a complete line with a 

semi-colon ( ; ) character like in C++.

• MySQL is case insensitive, on the contrary of C++.

• While the MySQL keywords are case insensitive, but in Linux, database name or 

table name (created by user) will be case sensitive. It is important.
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• Drop term in MySQL is basically same with delete.

• Record term in MySQL is row (table).

• Field term in MySQL is column (table).

Creating A Database

 

CREATE DATABASE mydatabase;

These command will create a database with the name mydatabase. 

Showing All Databases

 

SHOW DATABASES;

This command will show all databases you have.

Enter A Database

USE mydatabase;

To see tables inside a database, you must enter the database first. MySQL implements 

'USE' statement to do that.

Creating Table

 

CREATE TABLE bookstore ( id int unsigned NOT NULL AUTO_INCREMENT, title 

varchar(255) NOT NULL, author varchar(255), publisher varchar(255) NOT NULL, 

year varchar(4) NOT NULL, PRIMARY KEY (id) );

• This query will create a table with name bookstore, then

• create 5 columns by name id, title, author, publisher, and year,

• the first column will automatically numbered because it is integer (int) and has 

command AUTO_INCREMENT,

• varchar(255) is a limiter so every column will be limited into 255 characters.
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See Table Properties

DESCRIBE bookstore;

Output from this command will be: 

mysql> DESCRIBE bookstore;

+-----------+------------------+------+-----+---------+----------------+

| Field     | Type             | Null | Key | Default | Extra          |

+-----------+------------------+------+-----+---------+----------------+

| id        | int(10) unsigned | NO   | PRI | NULL    | auto_increment |

| title     | varchar(255)     | NO   |     | NULL    |                |

| author    | varchar(255)     | NO   |     | NULL    |                |

| publisher | varchar(255)     | NO   |     | NULL    |                |

| year      | varchar(255)     | NO   |     | NULL    |                |

+-----------+------------------+------+-----+---------+----------------+

5 rows in set (0.00 sec)

 

See Table Contents

SELECT * FROM bookstore;

This query (SELECT FROM)  will show complete form of a table. in this case, bookstore 

table. Output from this query will be like this: 

mysql> SELECT * FROM bookstore;

+----+---------+-------------------+---------------+------+

| id | title   | author            | publisher     | year |

+----+---------+-------------------+---------------+------+

|  1 | MY BOOK | SOMEONE AUTHORING | ANY PUBLISHER | 2000 |

+----+---------+-------------------+---------------+------+

1 row in set (0.00 sec)

 

Insert Data Into Table

INSERT INTO bookstore ( title, author, publisher, year ) VALUES ( "MY BOOK", 
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"SOMEONE AUTHORING", "ANY PUBLISHER", "2000" );

Output will be like this: 

mysql> SELECT * FROM bookstore;

+----+------------+-------------------+---------------+------+

| id | title      | author            | publisher     | year |

+----+------------+-------------------+---------------+------+

|  1 | MY BOOK    | SOMEONE AUTHORING | ANY PUBLISHER | 2000 |

|  2 | THEIR BOOK | THEY              | ANY PUBLISHER | 2001 |

+----+------------+-------------------+---------------+------+

2 rows in set (0.00 sec)

 

Edit A Table

 

UPDATE `bookstore` SET `year` = "1987" WHERE `bookstore`.`title` = "MY BOOK";

This query will edit data in the table. It will UPDATE bookstore table, by SET value 1987 

into a position. The position is column year and row MY BOOK. Important: notice the 

apostrophe and quote characters used above. Output will be like this: 

Query OK, 1 row affected (0.03 sec)

Rows matched: 1  Changed: 1  Warnings: 0

mysql> SELECT * FROM bookstore;

+----+------------+-------------------+---------------+------+

| id | title      | author            | publisher     | year |

+----+------------+-------------------+---------------+------+

|  1 | MY BOOK    | SOMEONE AUTHORING | ANY PUBLISHER | 1987 |

|  2 | THEIR BOOK | THEY              | ANY PUBLISHER | 2001 |

+----+------------+-------------------+---------------+------+

2 rows in set (0.00 sec)

 

Delete A Table
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DROP TABLE bookstore;

DROP TABLE query will delete a table specified. In this case, it will delete bookstore. You 

will not be able to SELECT a table which has deleted. Notice that DROP TABLE will delete 

all data inside your table. Output will be like this: 

mysql> DROP TABLE bookstore;

Query OK, 0 rows affected (0.06 sec)

mysql> SELECT * FROM bookstore;

ERROR 1146 (42S02): Table 'mydatabase.bookstore' doesn't exist

 

Delete A Database

DROP DATABASE mydatabase;

This query will delete a database. In this case, mydatabase. Notice that this will also 

delete all tables and all data inside. Output will be like this:

mysql> DROP DATABASE mydatabase;

Query OK, 1 row affected (0.11 sec)

mysql> USE mydatabase;

ERROR 1049 (42000): Unknown database 'mydatabase'

 

Summary

To help anyone learn MySQL quickly, we sum up all queries above here. Of course, these 

don't cover all you need with MySQL. It is just a beginning. 

• CREATE DATABASE mydatabase;

• SHOW DATABASES;

• USE mydatabase;

• CREATE TABLE bookstore ( id int unsigned NOT NULL AUTO_INCREMENT, title 

varchar(255) NOT NULL, author varchar(255), publisher varchar(255) NOT NULL, 
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year varchar(4) NOT NULL, PRIMARY KEY (id) );

• DESCRIBE bookstore;

• SELECT * FROM bookstore;

• INSERT INTO bookstore ( title, author, publisher, year ) VALUES ( "MY BOOK", 

"SOMEONE AUTHORING", "ANY PUBLISHER", "2000" );

• UPDATE `bookstore` SET `year` = "1987" WHERE `bookstore`.`title` = "MY BOOK";

• DROP TABLE bookstore;

• DROP DATABASE mydatabase;

References

• http://www.elated.com/articles/mysql-for-absolute-beginners   

• https://www.digitalocean.com/community/tutorials/a-basic-mysql-tutorial   
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HOW TO USE MATE FILE MANAGER (CAJA)

After PCManFM, we introduce here basic Caja File Manager usage. Caja is a descendant 

from the old Nautilus from GNOME 2.x era. You will find Caja File Manager in Ubuntu 

MATE, Linux Mint MATE, or any other distribution using MATE as its desktop 

environment.  It keeps many features from the past, such as emblems and split views. 

We use Caja 1.8.2 from Ubuntu MATE 14.04 here. We hope this will help new users. 

Enjoy.

Overview

 

1. Menu bar.

2. Tool bar (navigation, refresh, zoom, mode).

3. Address bar.

4. Left Panel (sidebar, view changer).

5. Status bar.

6. Main area.

Concepts
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• Caja is basically the old Nautilus from GNOME 2.x.

• Caja brings features from old Nautilus (i.e. emblem, split view, tree view) which 

have gone in the latest one.

Split View

To split main area, press F3. It is ont thing Caja keeps from the old Nautilus. Notice that 

Caja's F3 is different with Dolphin's F3. Caja may gives different tabs for every panel, 

while Dolphin gives a single tab showing two different panels. Caja's point of view is 

panel, while Dolphin's one is tab.

New Tab

To open a new tab, press Ctrl+T. To close a tab, press Ctrl+W.

New Folder

To create a folder, press Ctrl+Shift+N.

Sort By

To sort files, right-click on main area > Arrange Items > select one option.

Search

To search files, press Ctrl+F.
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Tree View

To change sidebar into tree view, click on selection above sidebar > select Tree View.

Adding Emblem

To add emblem into a folder, right-click a folder > Properties > open Emblems tab > 

check one or more emblem. 

Adding Background
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Caja can set background for main area. It can set plain color, pattern, or image. To set it, 

open menu Edit > Background and Emblems > a new window will appear > select a color 

or pattern > press Close. Main area will automatically changed. This example shows 

changing normal main area color into army camouflage pattern.

Change Folder Logo

To change a folder logo, right-click folder > Properties > click folder icon > select an 

image file > press Open. This example shows changing normal folder logo into Debian 

logo. Notice where we load images from (pixmaps folder). 

Change Folder Color

Specifically, Caja (in Ubuntu MATE) can change folder color directly from right-click 

menu. To do it, right-click folder > Folder's Color > select a color. See example below. 
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HOW TO USE KDE FILE MANAGER (DOLPHIN)

Now after Caja, we bring Dolphin. It is KDE file manager. We find Dolphin on Kubuntu, 

openSUSE, Slackware, or any other distro using KDE. We will explain briwfly how to use 

Dolphin to manage file and folder in Linux. We use Dolphin 14.12.3 in Kubuntu 15.04 

here. We hope this will help any new users. Enjoy.

Overview

 

1. Main toolbar. It consists of toolbar itself plus Control button (menubar inside a 

button, just like latest Chrome or Firefox web browser).

2. Address bar (breadcrumb or text).

3. Left Sidebar. By default, Dolphin has Places style.

4. Status bar. It consists of status indicator, zoom slider, or folder size bar.

5. Right Sidebar. By default, it is file preview panel.

Concepts

• Dolphin is an advanced file manager. By functionality, it is closer to Windows 

Explorer than any other file manager programs.

• Dolphin has split view, tree view, and show in groups feature while another file 

managers don't have it anymore.

• Dolphin builds its visual appearances from components. Sometimes it is toolbar, 
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sometimes it is panel. Every component can be added, modified, or removed. So it 

is possible to create custom toolbar with your choosen buttons in Dolphin, just 

like LibreOffice Writer toolbars.

• Dolphin has many panels. For example, tree view in Dolphin is treated as a special 

panel, named Folders Panel (F7).

• Dolphin doesn't have menubar by default, moved into single button Control.

Split View

To split view in Dolphin, press F3. Press it again to revert back.

New Tab

To open a new tab, press Ctrl+T. Press Ctrl+W to close it.

New Folder

To create a new folder, right-click main area > Create New > Folder. You can't use 

Ctrl+Shift+N by default because that shortcut has been used as New Window.
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Sort By

Dolphin is the only one file manager to do file sorting (by date or else) + Show in Groups. 

This feature can help us to easily differ a file from a another files in a folder. You ill find 

this feature in Windows Explorer too. To achieve this,

1. Open menu Control > Sort By > Date then select Descending.

2. Open menu Control > Sort By > Descending.

3. Open menu Control > Show in Groups.

4. This is our default view in Dolphin. If you want the other, change Date by Name, 

Type, or Size.
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Search

To search file in Dolphin, press Ctrl+F. Press Esc to revert back. Remember that KDE 

Baloo component needs some times (a few minutes) since the first run to index your 

files. Baloo is the new Nepomuk, the file indexing service in KDE. Baloo in KDE is similar 

with Google Search Engine in the web.

Tree View

Tree view in Dolphin is achieved by adding Tree Panel (Folders Panel) manually. To do it, 

press F7 or access Control > Panels > Folders. See picture below. Red box means how to 

do it, green box means the result. You may edit the panel positions by unlocking panel 

first then drag them then lock them again.

Change Folder Logo
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To change folder image, right-click a folder > Properties > click folder logo > select one 

image. In this example, we change default logo into red folder logo.

Integrated Terminal

To open Terminal directly inside Dolphin, press F4. To close it, press F4 again. It is an 

embedded Terminal, no need to open different window. Probably it is the most 

used/needed Dolphin feature for a Linux user.
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